Resolved
This incident has been resolved.
Monitoring
We’ve disabled Cloudflare proxying to restore and stabilize access to Grain. All Grain systems, including the dashboard, client APIs, and Query API, are now fully functional.
As a side effect, events ingested during this period will not include IP-based metadata (IP, region, country). All other event data and features are functioning normally.
Once Cloudflare’s incident is fully resolved, we’ll re-enable proxying and IP/geo enrichment for new events. Historical events collected during this window will remain without IP/geo fields.
Monitoring
Cloudflare is reporting partial recovery, and at this time the Grain dashboard and APIs (including Query API) are functioning normally again.
However, Cloudflare’s incident is still ongoing, so there remains a risk of renewed errors or brief outages while they continue remediation.
We’re monitoring closely and will keep this incident open until Cloudflare confirms full resolution. This remains an availability issue only; we do not expect any data loss.
When we gain access to DNS management features, we'll temporarily disable Cloudflare proxy for our APIs and dashboard as soon as possible to prevent any further downtime. At the moment, we are waiting for Cloudflare's DNS management to recover to take action.
Investigating
Cloudflare is currently experiencing a global internal service degradation, which is impacting Grain services that sit behind Cloudflare.
As a result, some users are intermittently unable to access the Grain dashboard, client APIs, and Query API, or may see higher-than-normal error rates.
We are monitoring Cloudflare’s incident, validating our own systems, and will restore normal operation as their network recovers.
No data loss is expected; this is an availability and connectivity issue only.
Investigating
Cloudflare is currently experiencing a global internal service degradation, which is impacting Grain services that sit behind Cloudflare.
As a result, some users are intermittently unable to access the Grain dashboard, client APIs, and Query API, or may see higher-than-normal error rates.
We are monitoring Cloudflare’s incident, validating our own systems, and will restore normal operation as their network recovers.
No data loss is expected; this is an availability and connectivity issue only.